routeos自动备份到FTP的代码

# 自动备份到FTP:local saveUserDb true;     # 是否保存用户数据库转储:local saveSysBackup true;  # 是否保存整个系统备份:local encryptSysBackup false; # 是否将系统备份(RouterOS的6.13及更高版本)加密:local saveRawExport true;  # 无论是出口整体配置为纯文本.RSC脚本

【小兵工作室官方下载】BING GHOST XP 集成驱动纯净版 2014.12

大城小我有话说:小兵系统干净无流氓软件,bing系统稳定不蓝屏黑频,估计是2014年最后一次更新了,这次集成了驱动,上次大城小我下载的没有集成驱动,有时候给用户安装又驱动的还是方便些。继续推荐大家使用小兵系统(我不是你眼中唯一将领  只是不起眼的小兵)˂img src="http://citywo.com/zb

【小兵工作室官方下载】BING GHOST XP 集成驱动纯净版 2014.12

Ros设置Vlan交换机以支持多线adsl

1、你可能没有四张网卡,需要用到Vlan交换机; 这个需要你的交换机支持802.1Q,所需要拨号的四个交换机端口(也就是连着四个ADSL猫的端口)都设置成access模式,vlanID分别是10、20、30、40(当然,其他的数字也可以)。连接RouterOS外线网卡的端口设置成trunk模式,并且允许以上vlan通过,在routeros的wan口建立4个vlan,vlanID分别为10、20、30、40(需要与交换机上的对应),这样就保证的了多个猫之间不会互相干扰,但是都可以和routeros上的虚拟vlan接口通讯。 /interface vlan add arp=enabled disabled=no interface=wan mtu=1500 name=vlan10 vlan-id=10 add arp=enabled disabled=no interface=wan mtu=1500 name=vlan20 vlan-id=20 add arp=enabled disabled=no interface=wan mtu=1500 name=vlan30 vlan-id=30 add arp=enabled disabled=no interface=wan mtu=1500 name=vlan40 vlan-id=40 2、ADSL无法拨上号,因为用来拨号的mac都一样; 如果你的vlan都是附着在wan口上面的,因此所有vlan虚拟接口的MAC地址都是同一个,因此电信局端检测到两个相同的mac在尝试用两个不同的账号同时拨号的时候就会断掉其中一个,这也是为什么有的无法同时拨号的原因。 解决办法就是通过添加桥即bridge,我感觉添加图片太麻烦,给出个脚本吧: /interface bridge add name=bridge10 admin-mac=11:11:11:11:11:11 disabled=no add name=bridge20 admin-mac=22:22:22:22:22:22 disabled=no add name=bridge30 admin-mac=33:33:33:33:33:33 disabled=no add name=bridge40 admin-mac=44:44:44:44:44:44 disabled=no /interface bridge port add bridge=bridge10 interface=vlan10 disabled=no add bridge=bridge20 interface=vlan20 disabled=no add bridge=bridge30 interface=vlan30 disabled=no add bridge=bridge40 interface=vlan40 disabled=no 这样,设置拨号的时候,选择interface为bridge10- bridge40,而不是vlan10-vlan40,这样子的话,拨号就不会存在mac地址冲突而无法拨号的情况了。  

ROS软路由小包优先策略

如果你需要做网络优化你可以做小包优先的策略。以下提供两种小包优先的配置方法较简单的小包优先配置方法:/ ip firewall mangle更改MSSadd chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1440 comment="" disabled=no 设置包大小0-32字节的为smalladd chain=forward packet-size=0-32 action=mark-packet new-packet-mark=small passthrough=yes comment="" disabled=no 设置包大小为33-511字节的为small_BIGadd chain=forward packet-size=33-511 action=mark-packet new-packet-mark=small _BIG passthrough=yes comment="" disabled=no 设置包大小为512-1500字节的为bigadd chain=forward packet-size=512-1500 action=mark-packet new-packet-mark=big passthrough=yes comment="" disabled=no parent=lan,lan是内网的接口,下面依次设置刚刚标记的包的优先级和带宽(带宽根据实际网络情况设置)  priority:small 5,small_BIG 6,big 8/ queue tree add name="small" parent=lan packet-mark=small limit-at=0 queue=default priority=5 max-limit=8M burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="small_big" parent=lan packet-mark=small_BIG limit-at=0 queue=default priority=6 max-limit=8M burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="big" parent=lan packet-mark=big limit-at=0  较详细的小包优先配置方法:/ ip firewall mangle add chain=forward protocol=tcp tcp-flags=syn action=change-mss new-mss=1440 comment="" disabled=no add chain=forward p2p=all-p2p action=mark-connection new-connection-mark=p2p_conn passthrough=yes comment="" disabled=no add chain=forward connection-mark=p2p_conn action=mark-packet new-packet-mark=p2p passthrough=yes comment="" disabled=no add chain=forward connection-mark=!p2p_conn action=mark-packet new-packet-mark=general passthrough=yes comment="" disabled=no add chain=forward packet-size=32-512 action=mark-packet new-packet-mark=small passthrough=yes comment="" disabled=no add chain=forward packet-size=512-1200 action=mark-packet new-packet-mark=big passthrough=yes comment="" disabled=no  / queue tree add name="p2p1" parent=WAN packet-mark=p2p limit-at=2000000 queue=default priority=8 max-limit=6000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="p2p2" parent=lan packet-mark=p2p limit-at=2000000 queue=default priority=8 max-limit=6000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="ClassA" parent=lan packet-mark="" limit-at=0 queue=default priority=8 max-limit=100000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="ClassB" parent=ClassA packet-mark="" limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="Leaf1" parent=ClassA packet-mark=general limit-at=0 queue=default priority=7 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="Leaf2" parent=ClassB packet-mark=small limit-at=0 queue=default priority=5 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no add name="Leaf3" parent=ClassB packet-mark=big limit-at=0 queue=default priority=6 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

ROS软路由小包优先策略

自动校准ROS系统时间

当你的ROS服务器主板电池没电的时候,可能会比较需要这个脚本,用来从网络上校准系统时间。system clock manual set time-zone=+8:00system ntp client set primary-ntp=210.72.145.44system ntp client set secondary-ntp=207.46.197.32system ntp client set enable=yes

ROS自动备份脚本

每隔2天,在01:30自动备份脚本:/system scheduleradd disabled=no interval=2d name=autobak on-event=\"/ file remove autobak.backup\r\\n/ system backup save name=autobak" policy=\ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \start-date=jan/04/2013 start-time=01:30:00

ros PPP定义突发限速

打开PPP-Profiles,修改模板对应Rate limit :

ros PPP定义突发限速

ros定时备份数据发送到邮箱

{ #定义全局变量:local from "abc@163.COM" :local user "abc" :local password "password" :local to "abc@163.com" :local cc "L5M_BACKUP@L5M.COM" :local address "123.125.50.133" :local router "L5M_ROS" #ROS 系统备份/system backup save name=($router."-".[:pick [/system clock get date] 7 11].[:pick [/system clock get date] 0 3].[:pick [/system clock get date] 4 6]); 

RouterOS 6.0 新功能介绍

RouterOS v6.0新功能 》已公布的和未公布的云核心设备将会全面支持RouterOS v6.x或者更高的版本 》RouterOS v6.0具有新的LINUX内核- RouterOS 5.21-LINUX内核版本为2.6.35- RouterOS 6.x-LINUX内核版本为3.3.5+

RouterOS 6.0 新功能介绍

ROS软路由小包优先策略

如果你需要做网络优化你可以做小包优先的策略。以下提供两种小包优先的配置方法较简单的小包优先配置方法:/ ip firewall mangle

ROS软路由小包优先策略

【来自ros软路由论坛】关于多ISP服务线路做PCC负载的方法,本例2电信,2联通

大城小我没有亲测,要用的朋友自己发现问题,谢谢天朝的特色,跨ISP互访延时不是一般的高,这就造成很多想做PCC负载时害怕出现的现象之一,特别是网页方面很明显。但稍作修改,这个问题可以得到比较满意的解决,注意,本例不考虑游戏分区的策略路由。出租屋嘛,最关键就是电影和网页流畅。当然,游戏也可以另做策略,但不在本例中。 以两条电信4M adsl,两条联通4M adsl为例,pppoe-out1 pppoe-out2 电信pppoe-out3 pppoe-out4 联通用户以pppoe方式上网,以下是pcc脚本和注意事项。

RouterOS 6.x 远程登陆,DDNS动态域名脚本(花生壳+3322公云)

一、花生壳  花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。  现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。脚本:

ROS检测当前年月日及时间并运行相关脚本

星期天是0表示,星期六是6表示,其它不解释:global NowDate [/system clock get date]:global NowYear ([:pick $NowDate 7 11]):global NowMonth ([:find jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec [:pick $NowDate 0 3]]+1):global NowDay [:pick $NowDate 4 6]:if ([:pick $NowDate 4 5] = 0) do={:set NowDay [:pick $NowDate 5 6]}:local C ([:pick $NowYear 0 2]):local Y ([:pick $NowYear 2 4]):local M $NowMonth:if ($NowMonth<3) do={:if ($Y<1) do={:set C ($C-1);:set Y 99} else={:set Y ($Y-1)}:set M ($M+12)}:local c1 ($C/4):local y1 ($Y/4):local m1 (13($M+1)/5):global NowWeek ($c1-$C2+$Y+$y1+$m1+$NowDay-1+7000):local w1 ($NowWeek/7):set NowWeek ($NowWeek-$w17):local week "日一二三四五六":set week ([:pick $week ($NowWeek2) ($NowWeek*2+2)]):local getT [/sys cl get time]:log warning ($NowYear . "年" . $NowMonth . "月" . $NowDay . "日 星期" . $week . " " . $getT):if ($NowWeek=0 ) do={/sys reboot}上面这句是如果今天是星期天那么就重启ROS

ROS DHCP黑名单管理

图片教程,欢迎查阅

ROS DHCP黑名单管理

push功能(强开首页)的辅助脚本,让用户每次拨号联机都能看到通告

第一个生存时间很短.一般20秒左右,第二个生存时间就起码4小时左右了,那么在这个期间用户掉线后,这个带D的IP地址仍然在地址列表里的直到它timeout,不管用户在期间上下线多少次,就只有第一次会有提示,通过这个脚本的弥补,用户断线后就自动清除地址列表里对应的IP,让每次客户连接都会看到强推首页.{:local ip/ip firewall address-list:foreach i in=[find list=src2] do={:set ip [get $i address]:if ([:len [/ip address find dynamic=yes network=$ip]]=0) do={remove $i}}}

ROS动态IP端口映射,解决回流问题

首先添加脚本,可直接在终端复制运行,也可按脚本进行图文添加/ip firewall nat add chain=dstnat dst-address=58.58.58.58 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.0.254 to-ports=80 comment="80"部分解释:dst-address=58.58.58.58 #这个你可以不用管他了..就用这个..会自动刷新更换,protocol=tcp #这个tcp为你映射端口所使用的协议..常见的有udpdst-port=80 #这里设置外网端口(外网端口可以设置和内网不一样)to-addresses=192.168.0.254 #这里设置你需要映射的内网IP地址to-ports=80 #这里设置你内网服务器需要映射的端口(建议大家不要用80,因为ADSL和拨号光纤的80端口是不开放的,)comment="80" #这里是一个关键,这里的80可以随便设置,但一定要和下面脚本中的comment一致.否则映射失败!建议使用外网端口!然后 添加刷新IP脚本(说白了把动态IP转成固定IP,这样大伙容易理解一点) 由于动态IP随时都可能改变,那么我们需要设置他运行的时间周期.这时我们需要用到ROS的计划任务功能(Scheduler)打开winbox --- system --- Scheduler里面设置脚本如下::global newipaddress:global lodipaddress:set newipaddress [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address]:set newipaddress [:pick $newipaddress 0 ([:len $newipaddress] -3)]:set lodipaddress [/ip firewall nat get [/ip firewall nat find comment="80"] dst-address]:if ($newipaddress != $lodipaddress) do={/ip firewall nat set [/ip firewall nat find comment="80"] dst-address=$newipaddress}部分解释:interface="pppoe-out1" #这里设置你PPPOE拔号的名称,注意大小写comment="80" #这里就是我们刚才说的关键了(上面蓝色部分).两处都一样.你上面设置什么.这里就一定要设置什么.否则此脚本失效!

routeos VRRP MAC地址修改-图片教程

很实用的功能,图片教程,欢迎查阅

routeos VRRP MAC地址修改-图片教程

企业三层交换网络(VLAN)+RouterOS解决方案

企业在使用路由器实现网络共享的过程中,都会用到企业三层交换网络的问题,这里网大以RouterOS软路由为例,教大家企业三层交换网络解决方案。这里我们以RouterOS 5.20和一台交换机为例。

企业三层交换网络(VLAN)+RouterOS解决方案