联系我们

深圳市大城小我信息技术服务有限公司

深圳市龙华区龙华街道华悦龙庭8楼

田先生

13428994037

13428994037

ROS第一次开网站跳转到公告页(任意地址跳转)方法

发布者:citywo发布时间:2014-07-10访问量:1988

本人未亲自测试,资料来源于网络,要用自己尝试

二种方法都能实现跳转,

我的网络是内网IP分流,

# jul/08/2011 13:59:56 by www.citywo.com
# software id = PIYV-S309
#
/ip firewall mangle
add action=add-src-to-address-list address-list=src2 address-list-timeout=1s \
chain=prerouting comment=”" disabled=no dst-port=80 protocol=tcp \
src-address=192.168.0.105-192.168.0.107 src-address-list=!src1

add action=add-src-to-address-list address-list=src1 address-list-timeout=1m \
chain=prerouting comment=”" disabled=no dst-port=80 protocol=tcp \
src-address=192.168.0.105-192.168.0.107 src-address-list=src2

/ip firewall nat
add action=redirect chain=dstnat comment=”" disabled=no dst-port=80 protocol=\
tcp src-address-list=src2 to-ports=8080

/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
cache-on-disk=no enabled=yes max-cache-size=unlimited \
max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=\
no src-address=0.0.0.0
/ip proxy access
add action=deny comment=”" disabled=no dst-port=80 redirect-to=\
192.168.0.247/index.html

这方法的mangle的顺序别搞错。



另一方法

ROS首页强开配置

/ip firewall nat
add action=dst-nat chain=dstnat comment=ToAddress disabled=no dst-port=80 protocol=tcp src-address-list=src1 to-addresses=192.168.88.1 to-ports=80

/ip firewall mangle
add action=add-src-to-address-list address-list=src1 address-list-timeout=3s chain=prerouting comment=TimeOut1 disabled=no dst-port=80 protocol=tcp src-address-list=!src2
add action=add-src-to-address-list address-list=src2 address-list-timeout=3h chain=prerouting comment=TimeOut2 disabled=no dst-port=80 protocol=tcp src-address-list=src1

备注:
1,192.168.88.1为内网首页强开WEB服务器IP。
2,强开3秒,强开过的IP在3小时内不会再强开。


本文标题:ROS第一次开网站跳转到公告页(任意地址跳转)方法
本文链接:http://citywo.com/index.php/post/75.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。